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About this Manual… 

User Information 

Be sure to store this manual in a safe place. 

Due to constantly growing product range, technical improvement and alteration or changed 

texts, figures and diagrams, we reserve the right of this manual contained information change 

without prior notice. 

Coping or reproducing any part of this manual, without written consent of Delta Electronics 

Inc. is prohibited. 

 

Technical Support and Service 

Welcome to contact us or visit our web site (http://www.delta.com.tw/industrialautomation/) 
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Chapter 1  Introduction 

1.1 eServer Data Collection Software 

eServer is a PC software used to help the customers collect and transfer production 

information and history data directly from production site to a PC in the office via Ethernet. 

eServer also supports Microsoft Excel (hereinafter “Excel”) software functions, such as 

formulas, tables and graphs. This allows that the collected data can be saved in user-defined 

Excel file according to various purposes for the customers to easily and quickly create 

required production reports. In addition, it also supports ODBC interface which is able to save 

the collected data to a database for the purpose of management and use in production sites.  
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1.2 Supported Models 

The supported models for eServer Data Collection Software are listed in the table below. 

Series Model Name Remark 

DOP-AE57BSTD 

DOP-AE57GSTD 

DOP-AE57CSTD 

DOP-AE80THTD1 

DOP-AE Series 

DOP-AE10THTD1 

DOP series Extension Ethernet 
Module, DOP-EXLNHJ1AE is 
required when using eServer 
with DOP-AE series HMI 
product. 

 

1.3 System Requirement 

Below are the system requirements to comply with the operating environment of eServer: 

Hardware / Software System Requirement 

CPU Pentium 4, 1.6GHz or greater is recommended 

Memory 1GB and above is recommended 

Hard Disk Capacity: 50MB and above 

Monitor Support resolution: 1024 × 768 or higher full-color display. 

Printer Printer compatible with Windows® 2000 & Windows® XP 

Operation System Windows® 2000 & Windows® XP 

Supported Microsoft 
Office Software 

Microsoft Office 2000 
Microsoft Office 2003 
Microsoft Office 2007 

 



Chapter 2  Software Installation 

2.1 eServer Setup 

In this chapter, it will introduce general functions of eServer with Windows. The users can use 

it to design what they want. Detail information for each function will be discussed in the 

following chapters. 

2.1.1 Software Installation 

To start the eServer setup, please refer to the following steps: 

Step 1. Please start-up your computer to Windows 2000/WindowsXP system. 
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Step 2. Execute setup.exe from Windows taskbar by clicking “Start” > “Run”. After 

pressing OK, the system will setup automatically and the following dialog box 

will appear for selecting the desired display language. 

 
 

Step 3. After pressing OK, the system will setup automatically and the users will get the 

following dialog box to choose destination location.  
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To select the default directory C: \Program Files\Delta Industrial 

Automation\DOP eServer 1.0, click Next> for the next step. Setup will install in 

the directory indicated in the Destination Directory box at the bottom of the 

dialog box. 

To select a directory other than the default directory, click Browse. A list of 

available directories appears. Highlight the desired directory for the Delta 

eServer and click OK, then Next> for the next step. 

If necessary, click < Back button to take you back through Setup dialog boxes 

one by one. 

 

Step 4. After pressing Next, the following dialog box will appear and ask the users to 

select the installation software, i.e. DOP eServer. Then click Install button to 

start DOP eServer installation. 
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Step 5. The system will start DOP eServer Installation. 

 

 

Step 6. DOP eServer has been installed successfully. Press Close to finish the installation. 
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Chapter 3  Before Using eServer 

Before using eServer, the users need to update HMI firmware and complete PC and HMI 

network settings. Please ensure to read the following instructions fully so that the users could 

understand how to update HMI firmware and complete PC and HMI network settings correctly. 

3.1 Update Firmware 

Remember to update the firmware before using eServer. To select this function, click Start > 

Programs > Delta Industrial Automation > HMI > DOP eServer 1.0 > Update Firmware 

Tool. 

 

After clicking Update Firmware Tool, the following dialog box will appear for the users to 

select the communication interface (the default setting is USB driver). Press Update button to 

update HMI firmware automatically. 
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3.2 Networking Settings  

Ensure to observe the following instructions to complete PC networking settings before 

eServer operation.  

3.2.1 Setting PC Network  

 

Power on PC and start Windows. Click Start > Programs, point to Control Panel, and then 

select Network Connections ( ).  

 

3-2   Revision April, 2010 



 Chapter 3  Before Using eServer 

Double-click Network Connections icon, the following windows will appear. Right-click 

the Local Area Connection icon, and then select Properties from the pop-up menu. 

 

The Local Area Connection Properties dialog box will open. Use General tab to select 

Internet Protocol (TCP/IP). Then, press Properties button. 
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The Internet Protocol (TCP/IP) Properties dialog box will open. Choose Use the 

following IP address and enter the IP address numbers of the PC into the field of IP 

address and Subnet mask.  

 

Then, press OK button to finish the settings. 

Please note that if the IP address numbers of subnet masks of the PC and HMI are 

different, HMI may not be displayed in the list when finding node.  
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3.2.2 Setting HMI Network 

Start Screen Editor software program and click Options > Configuration. Use 

Communication tab to select Ethernet and complete HMI networking settings shown as 

the figure below. Then, press OK button to finish the settings. 

 

Then, click Options > Networking. The following Remote Setting dialog box will appear. 

Check the check box before Enable eServer/Remote and set a password for network 

communication. After OK button is pressed, HMI networking is completed. Compile the 

edited project file at the end of the programming and the edited project file could be 

transferred to HMI.  
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3.3 Start eServer 

To start eServer, click Start > Programs > Delta Industrial Automation > HMI > DOP 

eServer 1.0 > eServer. 
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Chapter 4  Excel Sampling Setting 

4.1 Detailed Settings 

Please refer to the following steps to complete Excel sampling setting, i.e. how to log data 

from HMI to Excel. 

4.1.1 Linkage 

Start eServer, and click File > New or click New icon After the New dialog box is opened, 

select Logging (Excel) icon and press OK button.  

   

Then, the Excel Logging Wizard will be activated and the following dialog box will 

appear. Press Next button to continue.  
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Click New icon to access nodes (link to HMI). 

 

Click  icon to link HMI screen project file. There are two methods available for 

selection:  

1. Select an existing Screen (DOP) file from stored media:  Open an existing screen 

project file and set the IP address of the connecting HMI. 
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2. Transfer from Delta – HMI: Transfer the HMI screen project file via network 

communication directly. 

 

Press OK button to go to next step. 

 

4.1.2 Excel Template Sheet Design 

This step is used to create the desired Excel template sheet. There are two methods 

available for selection:  

1. Create a new Excel file: When this option is selected, the system will activate Excel 

automatically and allow the users to design the desired Excel template sheet. 

2. Select an existing Excel file from stored media: When this option is selected, the 

system will allow the users to open an existing Excel file. 
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Press Next button to go to next step. 

4.1.3 Excel Logging Range Setting 

This step is used to specify the logging range to which the sampling data will be written. 

There are three parts in this dialog box. 

 

 

1. Sampling Direction  

There are five different sampling directions could be selected. Please refer to the 

following table for explanation.  

Sampling Direction Diagram 

Multi-Vertical:  
When this option is selected, multiple 
numbers of different register data could 
be logged into each vertical column in 
the selecting area simultaneously.  

 

Multi-Horizontal:  
When this option is selected, multiple 
numbers of different register data could 
be logged into each horizontal row in the 
selecting area simultaneously.  

 



 

 
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Sampling Direction Diagram 

Single-Vertical:  
When this option is selected, only one 
number of register data could be logged 
into one cell for one time. The sampling 
operation is in vertical direction. The 
sampling operation of the second 
vertical column will not start unless the 
sampling operation of the first vertical 
column is done. Please refer to the right 
diagram.  

 

Single-Horizontal:  
When this option is selected, only one 
number of register data could be logged 
into one cell for one time. The sampling 
operation is in horizontal direction. The 
sampling operation of the second 
horizontal row will not start unless the 
sampling operation of the first 
horizontal row is done. Please refer to 
the right diagram. 

 

Anywhere: 
When this option is selected, the register 
data could be logged into any desired 
cell. 

 

 

2. Selection Range 

Press Excel button and the system will open the editing Excel template sheet 

immediately.  
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In Excel template sheet, use the mouse to decide the selection range. After the desired 

range is selected, press Close button to finish.  

 

3. Stamp Time and Date 

When this option is selected, the sampling time and date will be written as well 

automatically when the sampling data is recorded. The written position will be 

different depending on the setting sampling direction. Generally, the written position 

will be at the previous column or row before the selection range. However, if the 

following three conditions occur, the function of Stamp Time and Date will be disabled.  

a. When the sampling direction is vertical and the selection range includes column 

A (the first column).  

b. When the sampling direction is horizontal and the selection range includes row 

1 (the first row). 

c. When the sampling direction is anywhere.  
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The format of the date and time is specified by a string of characters which can be 

user-defined and changed freely. Please refer to the table below for the string 

representation.  

String Format Representation 

%m Month 

%d Date 

%y Year 

%H Hour 

%M Minute 

%S Second 

 

4.1.4 Register Setting 

This step is used to set the register address of the sampling data.  
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Setting Item Description Remark 

Sheet 
Excel Sheet index which the sampling data will be 
written 

Unchangeable

Cell Excel Cell which the sampling data will be written Unchangeable

HMI Name Name of connecting HMI  

Address Register Address   

Format 

1. When the register address is set to Bit, this 
data format setting will be disabled.  

2. When the register address is set to Word, this 
data format setting will be enabled and the 
available settings include: 
BCD, Signed, Unsigned, Hex, Floating, Char 
(Character) 

 

Unit Unit of the data length of the register Unchangeable

Read Count 

1. When the register address is set to Bit, this 
setting will be 1(one) always.  

2. When the register address is set to Word, the 
data format could be BCD, Signed, Unsigned, 
Hex, and Floating. But, note that the setting 
value of this field could not exceed 2(two). 

3. When the register address is set to Word, if the 
data format is set to Char (Character), the 
setting value of this field could be user-
defined and the max. setting value could be 
set to 100(hundred). 

 

Controller Connecting controller  Unchangeable
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4.1.5 Sampling Conditions 

This step is used to set the sampling conditions. There are two kinds of options for 

selection: 

1. Const (execute sampling repeatedly in a certain span of time)  

This option is used to determine how long the sampling process is repeated. The time 

unit is ms.  

 

 

 

 

 

 

 

 

 



Chapter 4  Excel Sampling Setting   

4-10   Revision April, 2010 

2. Trigger (Execute sampling when the trigger conditions are satisfied) 

This option is used to determine how long the sampling process is repeated when the 

trigger conditions are met. The detailed settings are described as follows:  

 

Polling Cycle (Sampling Cycle): It is used to determine how long the sampling process 

is repeated. The time unit is ms. 

Trigger Conditions: 

Setting Item Description Remark 

No. Condition number Unchangeable

Active 

Choose to activate the trigger conditions. 
The users can add many trigger conditions freely. 
When all the selected trigger conditions are satisfied, 
the system will execute the sampling operation for 
one time.  

 

 

HMI Name Name of connecting HMI  

Address Register Address   
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Setting Item Description Remark 

Format 

1. When the register address is set to Bit, the 
selectable options are: 
A. Level: Current status 
B. Rising edge: Triggered by rising-edge. At 

this time, the functions of Operator and 
Value are disabled.  

C. Falling edge Triggered by falling-edge. At 
this time, the functions of Operator and 
Value are disabled. 

2. When the register address is set to Word, the 
selectable options are:  
A. BCD: Setting range of trigger condition is 0 

~ 9999 
B. Signed: Setting range of trigger condition is  

-32768 ~ +32767 
C. Unsigned: Setting range of trigger 

condition is 0 ~ 65535 
D. Hex: Setting range of trigger condition is 0 

~ 65535 

 

Operator 

Operator settings: 
1. When the register address is set to Bit, the 

selectable operator are:  
A. = : equal to  
B. != : not equal to  

2. When the register address is set to Word, the 
selectable operator are: 
A. >= : greater than or equal to  
B. <= : smaller than or equal to  
C. > : greater than 
D. = : equal to  
E. < : smaller than 

Unchangeable

Value Setting value of trigger condition  

Controller Connecting controller Unchangeable
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4.1.6 Output Setting 

This step is used to set how to output and save the sampling data.  

 

There are two parts in this dialog box: 

1. Excel Sheet 

A. Repeat 

When the sampling data has been filled in the selection range to the full, the 

system will write the data into the selection range from the first column or row 

repeatedly.  

 



 
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B. Add a new file 

When the sampling data has been filled in the selection range to the full, the 

system will open a new Excel file automatically and write the data into the new 

Excel file.  

C. Add a new sheet  

When the sampling data has been filled in the selection range to the full, the 

system will open a new Excel sheet automatically and write the data into the new 

Excel sheet.  

 

 

2. Output Setting 

 

A. Location: Choose file destination location.  

B. Report File Name: Specify the name of the report file. The users can add the date 

and time in the end of the file name. The format of the date and time is specified 

by a string of characters which can be user-defined and changed freely. Please 

refer to the table below for the string representation.  

String Format Representation 

%m Month 

%d Date 

%y Year 

%H Hour 

%M Minute 

%S Second 
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C. Auto Save: When this option is enabled, the system will back up the data in a 

period of specified time automatically in case the data will be lost due to 

abnormal operation when the power source is cut off unexpectedly or other 

accident occurs.  



Chapter 5  Writing Data in Microsoft Excel 

Before creating testing example, make sure to change the upload and download option 

(Options > Configuration) on Screen Editor first. The default setting of upload and download 

is via USB. If the users need to use Ethernet, please change the default setting by referring to 

Appendix A. 

5.1 Example 

This example is used to help the users to understand how to use eServer to read the data of 

the register addresses $3 and $6 every second, record the data in Excel report file; meanwhile, 

calculate the average value of the register addresses $3 and $6 by using Excel formula and 

save the collected data in the specified folder (C:\Data). 

5.1.1 Create HMI Project File 

Start Screen Editor software program and click File > New or click New icon to create a 

new project. Then, click Element > Input > Numeric Entry to create two numeric entry 

elements ($3 and $6) on the screen. In this case, 10 inches color AE type DOP series HMI 

is used.  
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Use Screen Cycle Macro and enter the following commands in macro command window.  

 

Click Options > Configuration and use Communication tab to select Ethernet and 

complete HMI networking settings shown as the figure below. Then, press OK button to 

finish the settings. 
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Next, click Options > Network Setting. 

 

The following Remote Setting dialog box will appear. Check the check box before Enable 

eServer/Remote and set a password for network communication. After OK button is 

pressed, HMI networking is completed. Compile the edited project file at the end of the 

programming and the edited project file could be transferred to HMI.   
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5.1.2 eServer Setting 

1. After eServer is enabled, eServer  icon will appear at the bottom right of Windows 

screen.  

Right-click this icon and select Setting option from the pop-up menu.  

 

2. Then, eServer window will open.  

 

3. Click File > New or click  icon to create a new project file.  
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4. Select  icon to enable Excel Logging (Sampling) Wizard.  

 

 

Press Next button to go to next step. 
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5. Click New icon to access nodes (link to HMI).  

 

Choose Transfer from Delta – HMI option to transfer the HMI screen project file via 

network communication directly. Press OK button to go to next step. 
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6. Design Excel template sheet. Select Create a new Excel file option and press Next 

button to go to next step. 

 

The system will enable Excel automatically. Create a Excel template sheet as the 

figure below and enter the following formulas into the cells of E3 ~ E22 in order. 

Then, press Close button in the dialog box which appears at the bottom right of 

Windows screen to go to next step.  

 

Column Formula  Column Formula  

E3 =AVERAGE(C3:D3) E12 =AVERAGE(C12:D12) 

E4 =AVERAGE(C4:D4) E13 =AVERAGE(C13:D13) 

E5 =AVERAGE(C5:D5) E14 =AVERAGE(C14:D14) 

E6 =AVERAGE(C6:D6) E15 =AVERAGE(C15:D15) 

E7 =AVERAGE(C7:D7) E16 =AVERAGE(C16:D16) 

E8 =AVERAGE(C8:D8) E17 =AVERAGE(C17:D17) 

E9 =AVERAGE(C9:D9) E18 =AVERAGE(C18:D18) 

E10 =AVERAGE(C10:D10) E19 =AVERAGE(C19:D19) 

E11 =AVERAGE(C11:D11) E20 =AVERAGE(C20:D20) 
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7. Excel Logging Range Setting 

7.1 Set the sampling direction as Multi-Vertical. 

 

7.2 Press Excel button and the system will open the editing Excel template sheet 

immediately.  
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7.3 In Excel template sheet, the users can drag the mouse to select the selection 

range. In this case, C3 ~ D20 is selected. Then, press Close button to finish.  

 

7.4 Check the check box before Enable Stamp Time and Date function and change 

the format to %m/%d/%y %H:%M:%S. Once the sampling operation is enabled, 

the sampling date and time will be recorded into the cells of B3 ~B20.  

 

8. Set the register addresses.  
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Use the following dialog box to set the sampling register addresses.  

 

9. Set Logging Condition (Sampling Time) to 1000ms. 

 

10. Choose Add a new file in Excel Sheet and define the file location and file name 

shown as the figure below. After enabling the function of Auto Save, press Finish 

button to complete the settings. 
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11. Press  icon and enter the password. Then, the system will start sampling operation, 

i.e. writing data in Excel file.  
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12. If the users want to pause or stop the sampling operation, only right-click eServer  

icon at the bottom right of Windows screen and select Pause or Stop option from the 

pop-up menu, the sampling operation will pause and stop immediately. The users 

also can use Excel Visible option to decide whether the Excel window displays on the 

screen or not.  
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5.2 Detailed Settings 

Please refer to the following steps to complete Excel sampling setting, i.e. how to log data 

from HMI to Excel. 

5.2.1 Linkage 

Start eServer, and click File > New or click New icon After the New dialog box is opened, 

select Logging (Excel) icon and press OK button.  

   

Then, the Excel Logging Wizard will be activated and the following dialog box will 

appear. Press Next button to continue.  

 
Click New icon to access nodes (link to HMI). 
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Click  icon to link HMI screen project file. There are two methods available for 

selection:  

1. Select an existing Screen (DOP) file from stored media:  Open an existing screen 

project file and set the IP address of the connecting HMI. 
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2. Transfer from Delta – HMI: Transfer the HMI screen project file via network 

communication directly. 

 

Press OK button to go to next step. 

 

5.2.2 Excel Template Sheet Design 

This step is used to create the desired Excel template sheet. There are two methods 

available for selection:  

1. Create a new Excel file: When this option is selected, the system will activate Excel 

automatically and allow the users to design the desired Excel template sheet. 

2. Select an existing Excel file from stored media: When this option is selected, the 

system will allow the users to open an existing Excel file. 

 

Press Next button to go to next step. 
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5.2.3 Excel Logging Range Setting 

This step is used to specify the logging range to which the sampling data will be written. 

There are three parts in this dialog box. 

 

 

1. Sampling Direction  

There are five different sampling directions could be selected. Please refer to the 

following table for explanation.  

Sampling Direction Diagram 

Multi-Vertical:  
When this option is selected, multiple 
numbers of different register data could 
be logged into each vertical column in 
the selecting area simultaneously.  

 

Multi-Horizontal:  
When this option is selected, multiple 
numbers of different register data could 
be logged into each horizontal row in the 
selecting area simultaneously.  

 



 

 
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Sampling Direction Diagram 

Single-Vertical:  
When this option is selected, only one 
number of register data could be logged 
into one cell for one time. The sampling 
operation is in vertical direction. The 
sampling operation of the second 
vertical column will not start unless the 
sampling operation of the first vertical 
column is done. Please refer to the right 
diagram.  

 

Single-Horizontal:  
When this option is selected, only one 
number of register data could be logged 
into one cell for one time. The sampling 
operation is in horizontal direction. The 
sampling operation of the second 
horizontal row will not start unless the 
sampling operation of the first 
horizontal row is done. Please refer to 
the right diagram. 

 

Anywhere: 
When this option is selected, the register 
data could be logged into any desired 
cell. 

 

 

2. Selection Range 

Press Excel button and the system will open the editing Excel template sheet 

immediately.  
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In Excel template sheet, use the mouse to decide the selection range. After the desired 

range is selected, press Close button to finish.  

 

3. Stamp Time and Date 

When this option is selected, the sampling time and date will be written as well 

automatically when the sampling data is recorded. The written position will be 

different depending on the setting sampling direction. Generally, the written position 

will be at the previous column or row before the selection range. However, if the 

following three conditions occur, the function of Stamp Time and Date will be disabled.  

a. When the sampling direction is vertical and the selection range includes column 

A (the first column).  

b. When the sampling direction is horizontal and the selection range includes row 

1 (the first row). 

c. When the sampling direction is anywhere.  
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The format of the date and time is specified by a string of characters which can be 

user-defined and changed freely. Please refer to the table below for the string 

representation.  

String Format Representation 

%m Month 

%d Date 

%y Year 

%H Hour 

%M Minute 

%S Second 

 

 

5.2.4 Register Setting 

This step is used to set the register address of the sampling data.  
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Setting Item Description Remark 

Sheet 
Excel Sheet index which the sampling data will be 
written 

Unchangeable

Cell Excel Cell which the sampling data will be written Unchangeable

HMI Name Name of connecting HMI  

Address Register Address   

Format 

1. When the register address is set to Bit, this 
data format setting will be disabled.  

2. When the register address is set to Word, this 
data format setting will be enabled and the 
available settings include: 
BCD, Signed, Unsigned, Hex, Floating, Char 
(Character) 

 

Unit Unit of the data length of the register Unchangeable

Read Count 

1. When the register address is set to Bit, this 
setting will be 1(one) always.  

2. When the register address is set to Word, the 
data format could be BCD, Signed, Unsigned, 
Hex, and Floating. But, note that the setting 
value of this field could not exceed 2(two). 

3. When the register address is set to Word, if the 
data format is set to Char (Character), the 
setting value of this field could be user-
defined and the max. setting value could be 
set to 100(hundred). 

 

Controller Connecting controller  Unchangeable
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5.2.5 Sampling Conditions 

This step is used to set the sampling conditions. There are two kinds of options for 

selection: 

1. Const (execute sampling repeatedly in a certain span of time)  

This option is used to determine how long the sampling process is repeated. The time 

unit is ms.  
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2. Trigger (Execute sampling when the trigger conditions are satisfied) 

This option is used to determine how long the sampling process is repeated when the 

trigger conditions are met. The detailed settings are described as follows:  

 

Polling Cycle (Sampling Cycle): It is used to determine how long the sampling process 

is repeated. The time unit is ms. 

Trigger Conditions: 

Setting Item Description Remark 

No. Condition number Unchangeable

Active 

Choose to activate the trigger conditions. 
The users can add many trigger conditions freely. 
When all the selected trigger conditions are satisfied, 
the system will execute the sampling operation for 
one time.  

 

 

HMI Name Name of connecting HMI  

Address Register Address   
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Setting Item Description Remark 

Format 

1. When the register address is set to Bit, the 
selectable options are: 
A. Level: Current status 
B. Rising edge: Triggered by rising-edge. At 

this time, the functions of Operator and 
Value are disabled.  

C. Falling edge Triggered by falling-edge. At 
this time, the functions of Operator and 
Value are disabled. 

2. When the register address is set to Word, the 
selectable options are:  
A. BCD: Setting range of trigger condition is 0 

~ 9999 
B. Signed: Setting range of trigger condition is  

-32768 ~ +32767 
C. Unsigned: Setting range of trigger 

condition is 0 ~ 65535 
D. Hex: Setting range of trigger condition is 0 

~ 65535 

 

Operator 

Operator settings: 
1. When the register address is set to Bit, the 

selectable operator are:  
A. = : equal to  
B. != : not equal to  

2. When the register address is set to Word, the 
selectable operator are: 
A. >= : greater than or equal to  
B. <= : smaller than or equal to  
C. > : greater than 
D. = : equal to  
E. < : smaller than 

Unchangeable

Value Setting value of trigger condition  

Controller Connecting controller Unchangeable
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5.2.6 Output Setting 

This step is used to set how to output and save the sampling data.  

 

There are two parts in this dialog box: 

1. Excel Sheet 

A. Repeat 

When the sampling data has been filled in the selection range to the full, the 

system will write the data into the selection range from the first column or row 

repeatedly.  

 



 
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B. Add a new file 

When the sampling data has been filled in the selection range to the full, the 

system will open a new Excel file automatically and write the data into the new 

Excel file.  

C. Add a new sheet  

When the sampling data has been filled in the selection range to the full, the 

system will open a new Excel sheet automatically and write the data into the new 

Excel sheet.  

 

 

2. Output Setting 

 

A. Location: Choose file destination location.  

B. Report File Name: Specify the name of the report file. The users can add the date 

and time in the end of the file name. The format of the date and time is specified 

by a string of characters which can be user-defined and changed freely. Please 

refer to the table below for the string representation.  

String Format Representation 

%m Month 

%d Date 

%y Year 

%H Hour 

%M Minute 

%S Second 
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C. Auto Save: When this option is enabled, the system will back up the data in a 

period of specified time automatically in case the data will be lost due to 

abnormal operation when the power source is cut off unexpectedly or other 

accident occurs.  

 



Chapter 6  Writing Data in Microsoft Access 

Before creating testing example, make sure to change the upload and download option 

(Options > Configuration) on Screen Editor first. The default setting of upload and download 

is via USB. If the users need to use Ethernet, please change the default setting by referring to 

Appendix A. 

6.1 Example 

This example is used to help the users to understand how to use eServer to read the data of 

the register addresses $3 and $6 every second, record the data in Microsoft Access database 

via ODBC interface, and save the collected data into the specified folder (C:\Data). 

6.1.1 Database Setting 

1. Installing MSDE 

First download the free software MSDE from the Microsoft web site. To download it, go 

to http://www.asp.net/downloads/archived/msde/ and a download link will redirect 

the users to download it. 

After running the self-extracting file, open setup.ini file within MSDE subdirectory for 

editing.  

In the setup.ini file under the [Options] tag insert: 

SAPWD=”0000”  

SECURITYMODE=”SQL” 

The SAPWD is the password required for the system administrator (SA) login account. In 

this case, the SA login password is set to 0000. The users can set the desired password 

freely. Once the setup.ini file is saved, double-click setup.exe to complete MSDE 

installation. 
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2. Enabling MSDE  

Execute SVRNETCN.exe ( ) within C:\Program Files\Microsoft SQL 

Server\80\Tools\Binn subdirectory and enable Named Pipes and TCP/IP options.  

 

3. Setting Windows Firewall  

Click Start and then click Control Panel. In the Control Panel, click Windows Security 

Center > Windows Firewall. Then, click on the Exceptions tab. 
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Click Add Port button and the following Add a Port dialog box will appear.  

 

In the Add a Port dialog box, type SQL in the Name text field and type the port number 

of the instance of the Database Engine, such as 1433 for the default instance in the 

Port number text field. Ensure that TCP is selected and click OK to complete the 

settings. When SQL port is shown and selected in Windows Firewall dialog box, it 

indicates that SQL Server port will not be blocked and the incoming connections to SQL 

Server will be allowed.  
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4. Activating SQL Server  

Double-click the  located at the bottom right of Windows screen to open the 

following SQL Server Service Manager dialog box and click Start/Continue button.  

 

5. Starting Microsoft Access 

Start Microsoft Access by clicking Start > Programs > Microsoft Office > Microsoft 

Office Access. 

 

Name of SQL Server
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Then, click New icon and choose Project using new data to open a new database file 

and set the directory to C:\Data.  

 

Press Create button to enable Microsoft SQL Server Database Wizard.  

 

Press Next button to continue.  

Select Local or the name 
of the connecting SQL 
Server 

User’s name: sa 

User’s password: 0000 

Name of database: DELTA 
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Press Finish button to complete the settings.  

 

Then, click Design in the following pop-up window to create a database table in 

Design view.   
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In the Table dialog box, create a database like the following figure shown below. 

 

 

After editing the table, close the window to give a name for this table such as Table 1.  

 

Click OK button, and the following warning dialog will pop-up.  
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Please press No button to complete the settings. 

 

6. ODBC Setup 

In the Control Panel, double-click Administrative Tools.  

 

In the Administrative Tools, double-click Data Sources (ODBC). 
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In the ODBC Data Source Administrator dialog box, select System DSN tab and click 

on Add button to add system data source. 

 

Select SQL Server and then click on Finish button. 
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In the Create a New Data Source to SQL Server dialog box, do the following: 

Enter the name of the data source and select the SQL Server that the users want to 

access. 

 

Press Next button to continue.  

Choose how SQL Server should verify the authenticity of the login ID. Enter the user’s 

name and the password. In this case, the user’s name is sa and the password is 0000.  

Press Next button to continue.  
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Change the default database to DELTA.  

Press Next button to continue.  

 

Press Finish button.  
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Press OK button to complete ODBC setup.  
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6.1.2 Create HMI Project File 

Start Screen Editor software program and click File > New or click New icon to create a 

new project. Then, click Element > Input > Numeric Entry to create two numeric entry 

elements ($3 and $6) on the screen. In this case, 10 inches color AE type DOP series HMI 

is used.  

 

Use Screen Cycle Macro and enter the following commands in macro command window.  
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Click Options > Configuration and use Communication tab to select Ethernet and 

complete HMI networking settings shown as the figure below. Then, press OK button to 

finish the settings. 
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Next, click Options > Network Setting. 

 

The following Remote Setting dialog box will appear. Check the check box before Enable 

eServer/Remote and set a password for network communication. After OK button is 

pressed, HMI networking is completed. Compile the edited project file at the end of the 

programming and the edited project file could be transferred to HMI.   
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6.1.3 eServer Setting 

1. After eServer is enabled, eServer  icon will appear at the bottom right of Windows 

screen.  

Right-click this icon and select Setting option from the pop-up menu.  

 

2. Then, eServer window will open.  

 

3. Click File > New or click  icon to create a new project file.  
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4. Select  icon to enable ODBC Logging Wizard.  

 

 

Press Next button to go to next step. 

 

 

 

 

 

 

 

 

 

 



Chapter 6  Writing Data in Microsoft Access   

6-18   Revision April, 2010 

5. Click New icon to access nodes (link to HMI).  

 

Choose Transfer from Delta – HMI option to transfer the HMI screen project file via 

network communication directly.  

 

Press OK button to go to next step. 
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Press OK button to go to next step. 

 

6. ODBC Data Source Setting: Create an ODBC Data Source pointing to your database. 

Please refer to the following settings.  

 

Press Next button to go to next step. 
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7. Register Setting: Set the register address of the sampling data.  

 

8. Set the sampling conditions to constant 1000ms. Press Next button to continue. 
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9.  Press  icon. After the password is entered, the system will start sampling operation, 

i.e. writing data in Microsoft Access.  

    

 

10. If the users want to pause or stop the sampling operation, only right-click eServer  

icon at the bottom right of Windows screen and select Pause or Stop option from the 

pop-up menu, the sampling operation will pause and stop immediately.  
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6.2 Detailed Settings 

Please refer to the following steps to complete ODBC sampling setting, i.e. how to log data 

from HMI to a database. 

6.2.1 Linkage 

Start eServer, and click File > New or click New icon After the New dialog box is opened, 

select Logging (ODBC) icon and press OK button.  

   

Then, the ODBC Logging Wizard will be activated and the following dialog box will 

appear.  

Press Next button to continue.  
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Click New icon to access nodes (link to HMI). 

 

Click  icon to link HMI screen project file. There are two methods available for 

selection:  

1. Select an existing Screen (DOP) file from stored media:  Open an existing screen 

project file and set the IP address of the connecting HMI. 
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2. Transfer from Delta – HMI: Transfer the HMI screen project file via network 

communication directly. 

 

Press OK button to go to next step. 

 

6.2.2 ODBC (Open Data Base Connectivity) 

This step is used to create an ODBC Data Source pointing to your database.  
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Item Explanation 

ODBC Data Source Name of ODBC Data Source 

User Name Login Username 

Password Login Password 

Table Name of Sampling Data Table 

Time and Data Stamp Function: 

 

Item Explanation 

Time and Date Choose if Time and Date Stamp function is enabled. 

Table Table which the time and date will be written. 

Field Field which the time and date will be written. 

Detail The format of the date and time is specified by a string of 
characters which can be user-defined and changed freely. 
Please refer to the table below for the string representation.  

String Format Representation 

%m Month 

%d Date 

%y Year 

%H Hour 

%M Minute 

%S Second 
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6.2.3 Register Setting 

This step is used to set the register address of the sampling data.  

 

Setting Item Description Remark 

Table Table which the sampling data will be written Unchangeable

Field Field which the sampling data will be written  

HMI Name Name of connecting HMI  

Address Register Address   

Format 

1. When the register address is set to Bit, this 
data format setting will be disabled.  

2. When the register address is set to Word, this 
data format setting will be enabled and the 
available settings include: 
BCD, Signed, Unsigned, Hex, Floating, Char 
(Character) 

 

Unit Unit of the data length of the register Unchangeable

Read Count 

1. When the register address is set to Bit, this 
setting will be 1(one) always.  

2. When the register address is set to Word, the 
data format could be BCD, Signed, Unsigned, 
Hex, and Floating. But, note that the setting 
value of this field could not exceed 2(two). 
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Setting Item Description Remark 

Read Count 

3. When the register address is set to Word, if the 
data format is set to Char (Character), the 
setting value of this field could be user-
defined and the max. setting value could be 
set to 100(hundred). 

 

Controller Connecting controller  Unchangeable

 

6.2.4 Sampling Conditions 

This step is used to set the sampling conditions. There are two kinds of options for 

selection: 

1. Const (execute sampling repeatedly in a certain span of time)  

This option is used to determine how long the sampling process is repeated. The time 

unit is ms.  
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2. Trigger (Execute sampling when the trigger conditions are satisfied) 

This option is used to determine how long the sampling process is repeated when the 

trigger conditions are met. The detailed settings are described as follows:  

 

Polling Cycle (Sampling Cycle): It is used to determine how long the sampling process 

is repeated. The time unit is ms. 

Trigger Conditions: 

Setting Item Description Remark 

No. Condition number Unchangeable

Active 

Choose to activate the trigger conditions. 
The users can add many trigger conditions freely. 
When all the selected trigger conditions are satisfied, 
the system will execute the sampling operation for 
one time.  

 

 

HMI Name Name of connecting HMI  
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Setting Item Description Remark 

Address Register Address   

Format 

1. When the register address is set to Bit, the 
selectable options are: 
A. Level: Current status 
B. Rising edge: Triggered by rising-edge. At 

this time, the functions of Operator and 
Value are disabled.  

C. Falling edge Triggered by falling-edge. At 
this time, the functions of Operator and 
Value are disabled. 

2. When the register address is set to Word, the 
selectable options are:  
A. BCD: Setting range of trigger condition is 0 

~ 9999 
B. Signed: Setting range of trigger condition is  

-32768 ~ +32767 
C. Unsigned: Setting range of trigger 

condition is 0 ~ 65535 
D. Hex: Setting range of trigger condition is 0 

~ 65535 

 

Operator 

Operator settings: 
1. When the register address is set to Bit, the 

selectable operator are:  
A. = : equal to  
B. != : not equal to  

2. When the register address is set to Word, the 
selectable operator are: 
A. >= : greater than or equal to  
B. <= : smaller than or equal to  
C. > : greater than 
D. = : equal to  
E. < : smaller than 

Unchangeable

Value Setting value of trigger condition  

Controller Connecting controller Unchangeable
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Chapter 7  ODBC Sampling Setting 

7.1 Detailed Settings 

Please refer to the following steps to complete ODBC sampling setting, i.e. how to log data 

from HMI to a database. 

7.1.1 Linkage 

Start eServer, and click File > New or click New icon After the New dialog box is opened, 

select Logging (ODBC) icon and press OK button.  

   

Then, the ODBC Logging Wizard will be activated and the following dialog box will 

appear.  

Press Next button to continue.  
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Click New icon to access nodes (link to HMI). 

 

Click  icon to link HMI screen project file.There are two methods available for selection:  

1. Select an existing Screen (DOP) file from stored media:  Open an existing screen 

project file and set the IP address of the connecting HMI. 
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2. Transfer from Delta – HMI: Transfer the HMI screen project file via network 

communication directly. 

 

Press OK button to go to next step. 

 

7.1.2 ODBC (Open Data Base Connectivity) 

This step is used to create an ODBC Data Source pointing to your database.  
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Item Explanation 

ODBC Data Source Name of ODBC Data Source 

User Name Login Username 

Password Login Password 

Table Name of Sampling Data Table 

Time and Data Stamp Function: 

 

Item Explanation 

Time and Date Choose if Time and Date Stamp function is enabled. 

Table Table which the time and date will be written. 

Field Field which the time and date will be written. 

Detail The format of the date and time is specified by a string of 
characters which can be user-defined and changed freely. 
Please refer to the table below for the string representation.  

String Format Representation 

%m Month 

%d Date 

%y Year 

%H Hour 

%M Minute 

%S Second 
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7.1.3 Register Setting 

This step is used to set the register address of the sampling data.  

 

 

Setting Item Description Remark 

Table Table which the sampling data will be written Unchangeable

Field Field which the sampling data will be written  

HMI Name Name of connecting HMI  

Address Register Address   

Format 

1. When the register address is set to Bit, this 
data format setting will be disabled.  

2. When the register address is set to Word, this 
data format setting will be enabled and the 
available settings include: 
BCD, Signed, Unsigned, Hex, Floating, Char 
(Character) 

 

Unit Unit of the data length of the register Unchangeable

Read Count 

1. When the register address is set to Bit, this 
setting will be 1(one) always.  

2. When the register address is set to Word, the 
data format could be BCD, Signed, Unsigned, 
Hex, and Floating. But, note that the setting 
value of this field could not exceed 2(two). 
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Setting Item Description Remark 

Read Count 

3. When the register address is set to Word, if the 
data format is set to Char (Character), the 
setting value of this field could be user-
defined and the max. setting value could be 
set to 100(hundred). 

 

Controller Connecting controller  Unchangeable

 

7.1.4 Sampling Conditions 

This step is used to set the sampling conditions. There are two kinds of options for 

selection: 

1. Const (execute sampling repeatedly in a certain span of time)  

This option is used to determine how long the sampling process is repeated. The time 

unit is ms.  
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2. Trigger (Execute sampling when the trigger conditions are satisfied) 

This option is used to determine how long the sampling process is repeated when the 

trigger conditions are met. The detailed settings are described as follows:  

 

Polling Cycle (Sampling Cycle): It is used to determine how long the sampling process 

is repeated. The time unit is ms. 

Trigger Conditions: 

Setting Item Description Remark 

No. Condition number Unchangeable

Active 

Choose to activate the trigger conditions. 
The users can add many trigger conditions freely. 
When all the selected trigger conditions are satisfied, 
the system will execute the sampling operation for 
one time.  

 

 

HMI Name Name of connecting HMI  
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Setting Item Description Remark 

Address Register Address   

Format 

1. When the register address is set to Bit, the 
selectable options are: 
A. Level: Current status 
B. Rising edge: Triggered by rising-edge. At 

this time, the functions of Operator and 
Value are disabled.  

C. Falling edge Triggered by falling-edge. At 
this time, the functions of Operator and 
Value are disabled. 

2. When the register address is set to Word, the 
selectable options are:  
A. BCD: Setting range of trigger condition is 0 

~ 9999 
B. Signed: Setting range of trigger condition is  

-32768 ~ +32767 
C. Unsigned: Setting range of trigger 

condition is 0 ~ 65535 
D. Hex: Setting range of trigger condition is 0 

~ 65535 

 

Operator 

Operator settings: 
1. When the register address is set to Bit, the 

selectable operator are:  
A. = : equal to  
B. != : not equal to  

2. When the register address is set to Word, the 
selectable operator are: 
A. >= : greater than or equal to  
B. <= : smaller than or equal to  
C. > : greater than 
D. = : equal to  
E. < : smaller than 

Unchangeable

Value Setting value of trigger condition  

Controller Connecting controller Unchangeable

 



Chapter 8  Writing Data in MySQL 

Before creating testing example, make sure to change the upload and download option 

(Options > Configuration) on Screen Editor first. The default setting of upload and download 

is via USB. If the users need to use Ethernet, please change the default setting by referring to 

Appendix A. 

8.1 Example 

This example is used to help the users to understand how to use eServer to read the data of 

the register addresses $3 and $6 every second, record the data in MySQL via ODBC interface, 

and save the collected data into the specified folder (C:\Data). 

8.1.1 Software Installation 

1. AppServ Introduction 

AppServ is a free and full-featured software of Apache HTTP Server, MySQL, PHP, and 

phpMyAdmin. To download it, go to http://www.appservnetwork.com.  

Package of AppServ 

 Apache HTTP Server: It is a free and open source HTTP Server.  

 MySQL: It is a relational database management system. 

 PHP: It is a free and general-purpose scripting language designed for web 

development. 

 phpMyAdmin: It is web-based open source tool written in PHP for MySQL 

database management.  

After double clicking the appserv-win32-2.5.10.exe file downloaded from the website 

exe file, the following dialog box will appear. 
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Click on Run button to install AppServ. 

 

Click on Next button to go to the next step. 
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The users must read license agreement before installation. Click on I Agree button to 

continue. 

 

Select the default directory C:\AppServ, and click on Next button for the next step.  

To select a directory other than the default directory, click Browse.  
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Then, select the AppServ Package Components to install, and click on Next button for 

the next step. 

 

Specify Server Name, Administrator’s Email Address and Apache HTTP port for Apache 

Web Server. When perform testing, the Servo Name can be specified as localhost 

directly. Click on Next button for MySQL Server Configuration settings 
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Enter root password for MySQL database and complete the settings for MySQL Server.  

Character Sets and Collations: The users can select data storage language and 

collations from the drop-down menu.  

Old Password Support (PHP MySQL API function): When this option is selected, the users 

can code PHP code with old MySQL API.  

Enable InnoDB: When InnoDB is used, ensure to select this option.  

Click on Install button to installing Apache. 
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Click on Finish button to complete AppServ setup. 

 

After installing AppServ, the users can view the web site by pointing a web browser to 

http://localhost/. If the following screen displays, it indicates that Apache has been 

installed successfully. 

 

 

http://localhost/
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2. MySQL Settings 

Use phpMyAdmin built-in AppServ to perform the relevant MySQL settings. Open the 

browser, type: http://localhost/phpMyAdmin/, a Connect to localhost dialog box will 

display. Enter root for username and your password for password (The default 

administrator account is root, but depending on your setup it may be a different user 

name.) 

 

Then, it will connect to MySQL database. 

 

http://localhost/phpMyAdmin/
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A. Create New Database 

Click on Databases link. 

 

Enter the name of the new database. In this case, the name of the new database is 

entered as test. Click on Create button for the next step. 
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A new database has been created.  

 

 

B. Create New Table 

Click on Structure link to create new table on database. In this case, the new table is 

named as table1 and the number of fields is set to 3. After Go button is pressed, a new 

table on database will be created. 
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Complete the settings by referring to the figure below and press Save button to save 

changes.  

 

 

After the table1 has been created, the screen will be shown as follows.  
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C. Create New User 

Click on Privileges link to open User overview page. 

 

Click on Add a new User link to display the add new user page 
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Login Information: 

User name: Enter user name root 

Host: Select Any host from the drop down menu and insert a % code. 

Password: Enter the desired password 

Re-type: Re-enter the desired password 

General Password: 

 Click on Generate button to automatically generate a password. 

 Click on Copy button to insert the password into the fields of Password 

and Re-type. 

 

Scroll the screen down and click on Check All link to select all privileges. Then, click on 

GO button to create a new user.  
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A conformation message will be displayed as follows.  
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3. Setting Windows Firewall  

Click Start and then click Control Panel. In the Control Panel, click Windows Security 

Center > Windows Firewall. Then, click on the Exceptions tab. 

 

Click Add Port button and the following Add a Port dialog box will appear.  
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In the Add a Port dialog box, type MySQL in the Name text field and type the port 

ce 

4. Connector/ODBC Installation 

ized database driver which can be downloaded from 

number of the instance of the Database Engine, such as 3306 for the default instan

in the Port number text field. Ensure that TCP is selected and click OK to complete the 

settings.  

Connector/ODBC is a standard

MySQL website at http://dev.mysql.com/downloads/connector/odbc/5.1.html.  

 

5. ODBC Setup 

l Panel, double-click Administrative Tools.  In the Contro

 

 
 
 

http://dev.mysql.com/downloads/connector/odbc/5.1.html
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In the Administrative Tools, double-click Data Sources (ODBC). 

 

In the ODBC Data Source Administrator dialog box, select System DSN tab and click 

on Add button to add system data source. 
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Select MySQL ODBC 5.1 Driver and then click on Finish button. 

 

Now specify the Connection Parameters as mentioned in the below dialog. 

 

Connection Parameters: 

urce name eServer or enter the name of 

fy the connection.  

Data Source Name:  Enter ODBC data so

the data source you want to access.  

Description: Enter some text to identi
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Server: Enter the default localhost or the name of MySQL server host that the 

root to use for this connection. 

nnection.  

cess will be 

Click on Test button to verify the connection. If the test succeeds, the figure shown 

 

users want to access. 

User: Enter user name 

Password: Enter the corresponding password for this co

Database: The list of databases that the user has permissions to ac

shown automatically. 

 

below will appear on the screen to indicate that MySQL connection is now available to

use. At this time, click on OK button to complete the settings. If the test does not 

succeed, please review the settings.  

 



 Chapter 8  Writing Data in MySQL 

Revision April, 2010   8-19 

8.1.2 Create HMI Project File 

Start Screen Editor software program and click File > New or click New icon to create a 

new project. Then, click Element > Input > Numeric Entry to create two numeric entry 

elements ($3 and $6) on the screen. In this case, 10 inches color AE type DOP series HMI 

is used.  

 

Use Screen Cycle Macro and enter the following commands in macro command window.  
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Click Options > Configuration and use Communication tab to select Ethernet and 

complete HMI networking settings shown as the figure below. Then, press OK button to 

finish the settings. 
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Next, click Options > Network Setting. 

 

The following Remote Setting dialog box will appear. Check the check box before Enable 

eServer/Remote and set a password for network communication. After OK button is 

pressed, HMI networking is completed. Compile the edited project file at the end of the 

programming and the edited project file could be transferred to HMI.   
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8.1.3 eServer Setting 

1. After eServer is enabled, eServer  icon will appear at the bottom right of Windows 

screen.  

Right-click this icon and select Setting option from the pop-up menu.  

 

2. Then, opem eServer window.  

 

3. Click File > New or click  icon to create a new project file.  
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4. Select  icon to enable ODBC Logging Wizard.  

 

 

Press Next button to go to next step. 
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5. Click New icon to access nodes (link to HMI).  

 

Choose Transfer from Delta – HMI option to transfer the HMI screen project file via 

network communication directly.  

 

Press OK button to go to next step. 
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Press OK button to go to next step. 

 

6. ODBC Data Source Setting: Create an ODBC Data Source pointing to your database. 

Please refer to the following settings.  

 

Press Next button to go to next step. 
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7. Register Setting: Set the register address of the sampling data.  

 

8. Set the sampling conditions to constant 1000ms. Press Next button to continue. 
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9.  Press  icon. After the password is entered, the system will start sampling operation, 

i.e. writing data in MySQL Server.  

    
 

10. If the users want to pause or stop the sampling operation, only right-click eServer  

icon at the bottom right of Windows screen and select Pause or Stop option from the 

pop-up menu, the sampling operation will pause and stop immediately.  

 

 

11. Open the browser, type: http://localhost/phpMyAdmin/, and select the test database 

from the Database drop-down menu. 

 

 

http://localhost/phpMyAdmin/
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12. Click on Structure link. 

 

13. The recorded data will be shown at the bottom of the window. 
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9.1 Detailed Settings 

Please refer to the following steps to complete Excel sampling setting, i.e. how to log data 

from HMI to Excel. 

9.1.1 New Project 

Start eServer, and click File > New or click New icon  

 

After the New dialog box is opened, select Recipe Access icon and press OK button. 
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Click  icon to link HMI screen project file. There are two methods available for 

selection:  

1. Select an existing Screen (DOP) file from stored media:  Open an existing screen 

project file and set the IP address of the connecting HMI. 

 

2. Transfer from Delta – HMI: Transfer the HMI screen project file via network 

communication directly. 

 

Press OK button to go to next step. 
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9.1.2 Register Setting 

This step is used to set the register addresses of the database. There are two modes, 

Import and Export available for selection. After selecting the desired mode, choose Fixed 

or Variance from the drop-down list and complete the settings. 

Import - Fixed 

 

Import - Variance 

 

Setting Item Description Remark 

No. 
Excel Sheet index which the sampling data will be 
written. Unchangeable

Usage 
If the users want to select 16-bit recipe, enable 
this option by checking the check box. 

 

Name Recipe display name  

Type Recipe Bit type Unchangeable

HMI Name Name of connecting HMI Unchangeable

File Name 
1. When Fixed is selected:  

It is the file name of the imported file which 
could be changed and user-defined. 
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Setting Item Description Remark 

File Name 

2. When Variance is selected:  
It is the register address of a certain trigger 
element. 
Please note: When the data format is set to 
Word, the data format of the sampling register 
address could be Unsigned only. 

 

File Name 
Length 

Number of characters by referring the user-
defined file name.  

 

Controller Connecting controller  Unchangeable

Destination Path 
Destination location where the imported file is 
located.  

 

Export - Fixed 

 

Export - Variance 

 

Setting Item Description Remark 

No. 
Excel Sheet index which the sampling data will be 
written. 

Unchangeable

Usage 
If the users want to select 16-bit recipe, enable 
this option by checking the check box. 

 

Name Recipe display name  

Type Recipe Bit type Unchangeable

HMI Name Name of connecting HMI  
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Setting Item Description Remark 

Information Length and Group of the recipe. Unchangeable

File Name 

It is the register address of a certain trigger 
element. 
Please note: When the data format is set to Word, 
the data format of the sampling register address 
could be Unsigned only. 

 

File Name 
Length 

Number of characters by referring the user-
defined file name.  

 

Controller Connecting controller  Unchangeable

Source Path 
Destination location where the exported file is 
located. 

 

 

9.1.3 Sampling Conditions 

This step is used to set the sampling conditions. There are two kinds of options for 

selection: 

1. Const (execute sampling repeatedly in a certain span of time)  

This option is used to determine how long the sampling process is repeated. The time 

unit is ms.  

 

2. Trigger (Execute sampling when the trigger conditions are satisfied) 

This option is used to determine how long the sampling process is repeated when the 

trigger conditions are met. The detailed settings are described as follows:  
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Polling Cycle (Sampling Cycle): It is used to determine how long the sampling process 

is repeated. The time unit is ms. 

Trigger Conditions: 

Setting Item Description Remark 

Name. Condition number Unchangeable

HMI Name Name of connecting HMI  

Address Register Address   

Condition 

1. When the register address is set to Bit, the 
selectable options are: 
A. Level: Current status 
B. Rising edge: Triggered by rising-edge. At 

this time, the functions of Operator and 
Value are disabled.  

C. Falling edge Triggered by falling-edge. At 
this time, the functions of Operator and 
Value are disabled. 

2. When the register address is set to Word, the 
selectable options are:  
A. BCD: Setting range of trigger condition is 0 

~ 9999 
B. Signed: Setting range of trigger condition is  

-32768 ~ +32767 
C. Unsigned: Setting range of trigger 

condition is 0 ~ 65535 
D. Hex: Setting range of trigger condition is 0 

~ 65535 

 

Operator 

Operator settings: 
1. When the register address is set to Bit, the 

selectable operator are:  
A. = : equal to  
B. != : not equal to  

2. When the register address is set to Word, the 
selectable operator are: 
A. >= : greater than or equal to  
B. <= : smaller than or equal to  
C. > : greater than 
D. = : equal to  
E. < : smaller than 

Unchangeable
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Setting Item Description Remark 

Value Setting value of trigger condition  

Controller Connecting controller Unchangeable
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Chapter 10  Recipe Access Example 

Before creating testing example, make sure to change the upload and download option 

(Options > Configuration) on Screen Editor first. The default setting of upload and download 

is via USB. If the users need to use Ethernet, please change the default setting by referring to 

Appendix A. 

10.1 Creating Example 

Update Firmware 

Remember to update the firmware before using eServer. To select this function, click Start > 

Programs > Delta Industrial Automation > HMI > DOP eServer 1.0 > Update Firmware 

Tool. After clicking Update Firmware Tool, the following dialog box will appear for the users 

to select the communication interface (the default setting is USB driver). Press Update button 

to update HMI firmware automatically. 

 

Start eServer 

To start eServer, click Start > Programs > Delta Industrial Automation > HMI > DOP 

eServer 1.0 > eServer. 
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10.1.1 New Project 

Start eServer, and click File > New or click New icon  

 

After the New dialog box is opened, select Recipe Access icon and enter the file name 

exmple for the Recipe Access database. Then, press OK button. 
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10.1.2 Node 

Click  icon to link HMI screen project file. There are two methods available for 

selection. Here choose Select an existing Screen (DOP) file from stored media option to 

create a new node.  

Select an existing Screen (DOP) file from stored media 

Open an existing screen project file (HMI-recipe.dpb) and set the IP address of the 

connecting HMI. The IP address is set to 172.16.190.11 

 

Press OK button to go to next step. 
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After selecting the recipe file and setting the IP address, press OK button to go to next 

step. 

 

 

10.1.3 Setting and Condition - Import 

When the node is set correctly, click Setting and complete the settings next. There are 

two modes, Import and Export available for selection. Each mode provides two options, 

Fixed or Variance from the drop-down list for use. 

Import – Fixed 

Setting : 

a. Select Fixed. 

b. Check the check box to use 16-bit recipe as the example. 

c. User-define the Name (recipe display name) and File Name (file name of the imported 

file). 

d. Set Destination Path (destination location) where the imported file is located. 

 

b. 
a. 

c. d. 
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Condition : 

As for the method of sampling condition, select Const (execute sampling repeatedly in 

a certain span of time). 

a. Select Const. 

b. Choose Import. 

c. Set Polling Cycle (sampling cycle) to 1000ms (default setting value). 

 

a. 

b. 

c. 

After completing all the settings on eServer, use the most updated Screen Editor program 

editing software to open the selected .dpb file which just has been modified on eServer. 

Then, compile it and download the recipe data to HMI. The screen data will be shown as 

the figure below: 

 

After downloading the recipe data, please make sure that the IP address numbers of 

subnet masks of the PC (172.16.190.1) and HMI (172.16.190.11) are the same; otherwise, 

HMI may not be displayed in the list when finding node. 
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Networking Settings  

Ensure to observe the following instructions to complete PC networking settings before 

eServer operation.  

Setting PC Network  

 

Power on PC and start Windows. Click Start > Programs, point to Control Panel, and then 

select Network Connections ( ).  
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Double-click Network Connections icon, the following windows will appear. Right-click 

the Local Area Connection icon, and then select Properties from the pop-up menu. 

 

The Local Area Connection Properties dialog box will open. Use General tab to select 

Internet Protocol (TCP/IP). Then, press Properties button. 
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The Internet Protocol (TCP/IP) Properties dialog box will open. Choose Use the 

following IP address and enter the IP address numbers of the PC into the field of IP 

address and Subnet mask.  

 

Then, press OK button to finish the settings. 

Setting IP Address in HMI  

Enter into the system menu and set IP address to 172.16.190.11. Please see the figure 

below: 
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After networking settings are set correctly and successfully, return to eServer, save the 

file first and then run the recipe data. Please see the figure below: 

 

Press  icon. The following dialog box will pop-up and ask the users to enter the 

password.  

 

 Run Save 

Please enter 12345678 in the filed of the password at the first time (12345678 is the 

default setting value and the users can change it freely). After the correct password is 

entered, the  icon will display on the tool bar at the left-bottom corner.   

When eServer performs reading, the system will examine and check if the saved file name 

is saved in the destination path or not. Please refer to the figure such as . 

On the other hand, if incorrect or invalid password is entered, the following error 

message dialog box will appear to alert the users.  
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Import - Variance 

Setting : 

a. Select Variance. 

b. Check the check box to use 16-bit recipe as the example. 

c. Set the File Name (file name of the imported file) to be the same as the register 

address of HMI. (In this case $100  character input element is used) 

d. Set File Name Length (number of the imported characters). (In this case the File Name 

Length is set to 4. This is because the name of the imported file is Tina.csv. The 

system will refer to “Tina” these four characters and convert the imported file to 

Tina.rcp and then save it to the destination path. 

e. Set Destination Path (destination location) where the imported file is located. 

 

Condition : 

As for the method of sampling condition, select Const (execute sampling repeatedly in 

a certain span of time). 

a. Select Const. 

b. Choose Import. 

c. Set Polling Cycle (sampling cycle) to 1000ms (default setting value). 

 

b. 
a. 

c. e. d. 

a. 

b. 

c. 
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After completing all the settings, please make sure that the IP address numbers of subnet 

masks of the PC (172.16.190.1) and HMI (172.16.190.11) are the same; otherwise, HMI 

may not be displayed in the list when finding node. 

Networking Settings  

Ensure to observe the following instructions to complete PC networking settings before 

eServer operation.  

Setting PC Network  

 

Power on PC and start Windows. Click Start > Programs, point to Control Panel, and then 

select Network Connections ( ).  
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Double-click Network Connections icon, the following windows will appear. Right-click 

the Local Area Connection icon, and then select Properties from the pop-up menu. 

 

The Local Area Connection Properties dialog box will open. Use General tab to select 

Internet Protocol (TCP/IP). Then, press Properties button. 
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The Internet Protocol (TCP/IP) Properties dialog box will open. Choose Use the 

following IP address and enter the IP address numbers of the PC into the field of IP 

address and Subnet mask.  

 

Then, press OK button to finish the settings. 

Setting IP Address in HMI  

Enter into the system menu and set IP address to 172.16.190.11. Please see the figure 

below: 
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After completing all the settings and make sure that the communication is good, use the 

most updated Screen Editor program editing software to open the selected .dpb file which 

just has been modified on eServer. Create a character input element and set its address to 

$100.  

 

$100 

Then, compile it and download the recipe data to HMI. After recipe data is downloaded to 

HMI successfully, return to eServer, save the file first and then run the recipe data. Next, 

trigger the character input element on HMI, and the system will save the imported file to 

the destination path. Please see the figure below: 

 
 Run Save 
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Press  icon. The following dialog box will pop-up and ask the users to enter the 

password.  

 

Please enter 12345678 in the filed of the password at the first time (12345678 is the 

default setting value and the users can change it freely). After the correct password is 

entered, the  icon will display on the tool bar at the left-bottom corner.   

When eServer performs reading, please trigger the character input element on HMI and 

enter TINA these four characters. Please refer to the figure below: 
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Then, the system will examine and check if the saved file name is saved in the destination 

path or not. Please refer to the figure such as . 

On the other hand, if incorrect or invalid password is entered, the following error 

message dialog box will appear to alert the users.  

 
 

10.1.4 Setting and Condition - Export 

Export – Fixed 

Setting : 

a. Select Fixed. 

b. Check the check box to use 16-bit recipe as the example. 

c. Information shows the length and the group of the recipe data. 

d. Set Destination Path (destination location) where the imported file is located. 

Please note: the value of the selected -0223.rcp file (item d.) is the downloading value 

when the element is triggered on HMI. 
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a. 
c. d. b. 

 

Condition : 

As for the method of sampling condition, select Trigger (Execute sampling when the 

trigger conditions are satisfied). 

a. Select Trigger. 

b. Set Address to the register address of the trigger element. (In this case the trigger 

element is a numeric input element and its address is set to $200) 

c. Set Operator and Value to = and 4. (In this case it indicates that when 4 is entered on 

HMI, the system will trigger the element and export the file) 

 

c. b. 

a. 

After completing all the settings, please make sure that the IP address numbers of subnet 

masks of the PC (172.16.190.1) and HMI (172.16.190.11) are the same; otherwise, HMI 

may not be displayed in the list when finding node. 

Networking Settings  

Ensure to observe the following instructions to complete PC networking settings before 

eServer operation.  
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Setting PC Network  

 

Power on PC and start Windows. Click Start > Programs, point to Control Panel, and then 

select Network Connections ( ).  

 

Double-click Network Connections icon, the following windows will appear. Right-click 

the Local Area Connection icon, and then select Properties from the pop-up menu. 
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The Local Area Connection Properties dialog box will open. Use General tab to select 

Internet Protocol (TCP/IP). Then, press Properties button. 

 

The Internet Protocol (TCP/IP) Properties dialog box will open. Choose Use the 

following IP address and enter the IP address numbers of the PC into the field of IP 

address and Subnet mask.  
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Then, press OK button to finish the settings. 

Setting IP Address in HMI  

Enter into the system menu and set IP address to 172.16.190.11. Please see the figure 

below: 

 

After completing all the settings and make sure that the communication is good, use the 

most updated Screen Editor program editing software to open the selected .dpb file which 

just has been modified on eServer. Create a numeric input element and set its address to 

$200.  
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$200 

Then, compile it and download the recipe data to HMI. After recipe data is downloaded to 

HMI successfully, return to eServer, save the file first and then run the recipe data. Next, 

trigger the numeric input element on HMI, and the system will save the imported file to 

the destination path. Please see the figure below: 

 
 Run Save 

Press  icon. The following dialog box will pop-up and ask the users to enter the 

password.  
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Please enter 12345678 in the filed of the password at the first time (12345678 is the 

default setting value and the users can change it freely). After the correct password is 

entered, the  icon will display on the tool bar at the left-bottom corner.   

When eServer performs reading, please trigger the numeric input element on HMI and 

enter the value of 4. Then, the system will convert the recipe data to the data of  

-0223.rcp and show on HMI screen. 

Please refer to the figure on next page: 
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On the other hand, if incorrect or invalid password is entered, the following error 

message dialog box will appear to alert the users.  

 

 

Export - Variance 

Setting : 

a. Select Variance. 

b. Check the check box to use 16-bit recipe as the example. 

c. Set the File Name (file name of the imported file) to be the same as the register 

address of HMI. (In this case $100  character input element is used.) 

d. Set File Name Length (number of the imported characters). (In this case the File Name 

Length is set to 4. This is because the name of the exported file is Tina.csv. This file 

will be open in Screen Editor and save the value into .csv file.) 

e. Set Source Path (destination location) where the exported file is located (Tina.csv file 

is saved in C:\). 
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Condition : 

As for the method of sampling condition, select Trigger (Execute sampling when the 

trigger conditions are satisfied). 

a. Select Trigger. 

b. Set Address to the register address of the trigger element. (In this case the trigger 

element is a numeric input element and its address is set to $200) 

c. Set Operator and Value to = and 4. (In this case it indicates that when 4 is entered on 

HMI, the system will trigger the element and export the file) 

 

After completing all the settings, please make sure that the IP address numbers of subnet 

masks of the PC (172.16.190.1) and HMI (172.16.190.11) are the same; otherwise, HMI 

may not be displayed in the list when finding node. 

a. 

b. c. 

a. 
b. c. e. d. 



Chapter 10  Recipe Access Example   

Networking Settings  

Ensure to observe the following instructions to complete PC networking settings before 

eServer operation.  

Setting PC Network  

 

Power on PC and start Windows. Click Start > Programs, point to Control Panel, and then 

select Network Connections ( ).  

 

Double-click Network Connections icon, the following windows will appear. Right-click 

the Local Area Connection icon, and then select Properties from the pop-up menu. 
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The Local Area Connection Properties dialog box will open. Use General tab to select 

Internet Protocol (TCP/IP). Then, press Properties button. 

 

The Internet Protocol (TCP/IP) Properties dialog box will open. Choose Use the 

following IP address and enter the IP address numbers of the PC into the field of IP 

address and Subnet mask.  
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Then, press OK button to finish the settings. 

Setting IP Address in HMI  

Enter into the system menu and set IP address to 172.16.190.11. Please see the figure 

below: 
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After completing all the settings and make sure that the communication is good, use the 

most updated Screen Editor program editing software to open the selected .dpb file which 

just has been modified on eServer. Then, create two elements. One is a character input 

element and its address is set to $100. The other is a numeric input element and its 

address is set to $200. Please refer to the figure below: 

  

$100 $200 

Then, compile it and download the recipe data to HMI. After recipe data is downloaded to 

HMI successfully, return to eServer, save the file first and then run the recipe data. Next, 

trigger the numeric input element on HMI, and the system will save the imported file to 

the destination path. Please see the figure below: 

 
 Run Save 

 

Press  icon. The following dialog box will pop-up and ask the users if it is necessary to 

convert the file of Tina.csv.  
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Check the box before Translate All and press OK button, the following dialog box will 

pop-up and ask the users to enter the password.  

 

Please enter 12345678 in the filed of the password at the first time (12345678 is the 

default setting value and the users can change it freely). After the correct password is 

entered, the  icon will display on the tool bar at the left-bottom corner.   

When eServer performs reading, please trigger the character input element (TINA) and the 

numeric input element (4) on HMI. Then, the system will convert the recipe data to the 

record data of Tina.csv file.  

Please refer to the figure on next page: 
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On the other hand, if incorrect or invalid password is entered, the following error 

message dialog box will appear to alert the users.  
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A.1 Configuration Settings  

The default setting of upload and download on Screen Editor is via USB. If the users need to 

use Ethernet, please activate Screen Editor and select Options > Configuration to access the 

configuration options and change the upload and download setting. 
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In Configuration dialog box, change the default setting of upload and download to Ethernet. 

Then, press OK to complete the setting.  
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A.2 COM Port Settings  

If the users choose to use DHCP mode, it is not necessary to set Ethernet IP address in COM 

Port tab. 
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If the users choose to use user-defined IP address, please set Ethernet IP address in COM Port 

tab and ensure that the domain name is the same as the IP address of the personal computer.  

 

After Ethernet IP address is set, the users can enter into the system menu to verify if the IP 

address is written correctly or not.  
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Then, observe the following instructions to complete PC networking settings. 

 

Power on PC and start Windows. Click Start > Programs, point to Control Panel, and then 

select Network Connections.  
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Double-click Network Connections icon, the following windows will appear. Right-click the 

Local Area Connection icon, and then select Properties from the pop-up menu. 

 

The Local Area Connection Properties dialog box will open. Use General tab to select 

Internet Protocol (TCP/IP). Then, press Properties button. 
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The Internet Protocol (TCP/IP) Properties dialog box will open. Choose Use the 

following IP address and enter the IP address numbers of the PC into the field of IP 

address and Subnet mask.  

 

 

Then, press OK button to finish the settings. 

Please note that if the IP address numbers of subnet masks of the PC and HMI are 

different, HMI may not be displayed in the list when finding node.  
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A.3 Compile and Upload / Download Screen & Recipe 

After completing PC networking settings, compile the editing program immediately. When 

compile operation is performed successfully, choose Upload Screen & Recipe or Download 

Screen & Recipe next.  
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Then, the following dialog box will appear.  

 

The users can check the box before Auto Search, and the system will detect the connecting 

HMI automatically. 

 

When the connecting HMI is found, press Start button, and the system will start to upload or 

download the screen data via Ethernet immediately.  
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